Hi Patrycja, For me it seems that the plugins needed to import and open the models in Tekla BIMsight are most probably not correctly installed, and therefore, you're not able to view any models. To make sure that this is the case, please check from the Control Panel can you found the same plugins there as in the attached snapshot. If these plugins are missing, please uninstall all Tekla BIMsight related programs from the Control Panel and reinstall Tekla BIMsight again with the following instructions. 1. Remove your current Tekla BIMsight installation by running Microsoft repair tool http://support.microsoft.com/mats/Program_Install_and_Uninstall/ by right clicking it and selecting “run as administrator”. 2. Restart your computer, download the latest version again here http://www.teklabimsight.com/downloads.jsp and copy the installer package to the desktop. 3. Run Tekla BIMsight installer with an user account that has local administrator rights. Before running the installer please check that the download has been successful and the digital signature is OK. To do this, right-click the installer, select properties, then Digital Signatures tab, click on the signature and then the Details button. The dialog that opens should say that the signature is OK. Hope these instructions will solve the problem and if the issue still continues please let me know and we’ll help you further with the case. Thanks, Heikki http://www.teklabimsight.com/photo.jsp?key=55c8433d-3b62-83cc-bdb3-00007dd5f40d